Super Magic Timer Problem [Solved]

Home Forums Free Flight FAI Models & Flying Super Magic Timer Problem [Solved]

  • This topic has 7 replies, 5 voices, and was last updated 15 years ago by Anonymous.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #40820


    I recently switched to using a Palm Tungsten T3 so that I would have a reliable device for both BlackMagic and the MTK timer. With that, I have SerialFix software installed on the T3 because of the well known serial bug that is found in the T3 OS.

    I am using a cable purchased from Serialio which is an adapter from the Palm Universal Connector to Rs232, then connected to a null modem, then to the standard 2.5mm jack.

    During the first time sending a program into the timer, the Palm beeped midway in the data transfer. This interruption was immediately followed by the servos in the model moving at unusually slow speeds.

    After this interruption in data transfer, the timer never behaved normal again. Every time the timer was resetted, the timer will start beeping the DT time in the model but immediately go into an endless loop of beeping. The beeping however occurs in a pattern like a metronome.

    There is no way to communicate to the timer as trying to connect to the timer results in a string of error messages on the Palm.

    When I disconnect the battery from the timer, let the timer sit for a while, then reconnect the battery, and turn on the timer, the timer goes into a constant low pitched sound like the sound heard when the hook is held at high tension after unlatch. Pushing the hook forward stops this noise, but letting the hook back again causes the noise to start again. Resetting the timer simply puts it into the endless loop of beeping again.

    So, I would like to ask the question: If the data transfer between the Palm and the timer was interrupted in the middle of programming, is there a way to put in a good program, will I need to send the timer back to Roger Morrell to get it fixed, or will I need a new timer?

    Yes, I have read Roger’s errorcheck document concerning the timer syntax checking feature. It notes that erratic timer behavior may be caused by the sportsmen interrupting the data transfer (this what I think my condition is although the palm somehow interrupted the transfer by itself). It is unlikely that this is caused by a “brownout situation” since I was using a fully-charged battery at the time.

    I would appreciate some advice on what to do with this situation. I have already emailed Roger and I’m waiting for a reply. I hope to get this model up and running as soon as I can.


    Oliver Cai


    Hello Oliver

    There should be no problem with the Black Magic circuit board. Try programming with another Palm Pilot and upload the program from the model again.

    Interruption during program means that you don’t have a valid connection, and nothing is changed in the timer.

    I have 3 Palm Pilots, one a TRX which I use for both Black Magic and M&K.

    I finally got the new M&K program that allows an upload, but have not tried using it yet.

    Anyhow, go back to a standard Palm IIIXE, and give that a try with a known good cable.

    These Palm pilots are touchy, and sometimes the cables are also unreliable.

    You most likely don’t have anything wrong other than your new Palm system does not work or is not setup right.


    I agree with Dave, get another Palm and download a good program.

    I do wonder if you have chanced upon the world domination program that Lord Magic keeps in his timer for when its needed. The plan is, so I hear, that on a specific day (that can be brought forward using RDT) that all the BMTs will morph together into some sort of huge ‘transformer’-type device that will display via the thousands of LEDs the words ‘Fly FIB’.

    Roger Morrell

    I’m going to my secret mountauin retreat, near the real EoB, in a couple weeks uner the cover of the Omarama Cup to further plan world domination…

    On Oliver’s problem, Victor and I have been communicating with him directly.

    Lord Magic



    ***This is the email I sent to Roger and Victor.

    The issue has been fixed. 🙂 Due to my lack of knowledge of batteries (and electronics in general), I assumed that each cell of a NiMH battery is around 1.2 volts. With 4 cells in the battery pack in serial, I assumed that full voltage should be 4.8 volts. A charge using an automatic discharge/charge program in a smart charger put the battery near 6 volts at full charge (now ~5.3 when put on a voltmeter under load).

    So, I guess that the battery was low after all. Does low battery cause strange timer behavior like this though?

    I was relieved when the timer behaved totally normal when I connected the charged battery. I tested it with the T3 again and it does work properly now.

    Thank you very much for your help,




    It seems strange that a timer battery voltage should have caused your problem. I’m using a single Lipo for 1 (BMT) and 2 servos models and that’s OK even at around 3.85v. I use a voltage booster on my 3 servo model (BMT) that pumps it up to 5v and again it is perfect. Normally a low battery (NiMH) causes the servos to slow up and judder (more) but I never had a problem in loading the program in such circumstances.

    Think world domination program – when Governer Magic goes to his mountain retreat you just know its going to be ‘big trouble’. Also, why did he call his latest timer the ‘universe timer’ ………………

    Anyway, glad its sorted.

    Roger Morrell

    CHE and Oliver

    The reason is to do with the model of PP, model of timer, the number of servos and the type of battery. The SMT timer is 4 servos. Oliver’s battery is a large NiMH. This is the battery that Victor recommends, however a LiPoly has much lower internal resistance and the voltage does not fall off under load as does the typical NiMH. CHE’s model have less servos and he used a different PP.

    While we use a serial protocol to communicate between the timers and PP it is not true RS-232 spec. The voltage is much lower. It turns out that the Palm III and TRGs are the least senstive to voltage, the M series has other characteristics and the Tungstens some thing different again.

    Any one who has flown R/C partcularily years ago when I was so misguided and battery technology was not was good as now would have never flown an airplane that they had not charged that morning or at the latest the night before. I was not surprised when another customer told me he had trouble because he has not charged his baterry for a couple of contests, I just did not think that anyone would not charge before every contest as a matter or course.


    Electric Timer rules:

    Assuming you have a good cable and good program in the Black Magic:
    First, try a new battery.
    Second, Test switches with a meter.
    Third, unplug servo one at a time and replace with a “known” good plug

    Per Roger, less than 15% of the timers sent to him for repair need repair, its usualy one of the above.

    Other recent F1A Black Magic lessons learned:

    Hector Diez– single grain of sand got in the hook forward micro switch lever preventing the forward switch singal thus putting the timer in DT time reset mode and it continued to beep away. Lesson: Keep switches clean.

    Hector Diez– somehow the Fly-a-way number got set to zero resulting in no circle tow / bunt (ie the timer sent DT command). Lesson: learn the settings on the More Screen- a quick check could save a lot of trouble shooting time.

    Jon Davis– some how the hook bounce got set to zero. After an hour of checking switched with a meter, hooking up good servoes, new battery, the enlightenment came when the timer worked when test releasing the latch but when the hook was forward and the hook was pulled to relase the latch the timer went to bunt (hook still forward). The shock from the keeper release shocked the reed switch to closed position. Reset the hook bounce to 12 and all is well. Lesson: repeat of above–

    Jon Davis: Jon soldered the battery connector directly to the timer pins– an earlier timer with th smaller pins. A pin fatigued and cracked causing intermentent contct / failure. we field solder the wire directly to the board for the MaxMen. Jon don’t forget you need to do the the correct fix. New pins and connector / wire. In full disclousure, I initially set this model up– I put the battery pins on the top of the timer so the battery connector could be made easily- worked well initially but long term bad idea, too much battery wire movement. I have learned and no longer solder to the Black Magic at all– Roger does not frown at me now. Lesson: do not solder to timer

    Lee Hines: picked up iron particles when flying down under on switch magnets causing irractic opperation. Removing iron particle fixed the problem. Lesson- keep you magnets clean.

    Jim Parker: Dare I mention RDT again??? Installed a Bauer RDT on a new model which did not seem to work. Fortunately, the model sitting in the work shop DT before the 3 minute setting it had. Turns out I had put 1 minute time on the line the RDT is set to (Line 10 is what I use). The RDT worked but the minute had to count down before DT’ing. Lesson- set the RDT line time to zero.

    Jim Parker: Similar to above. After installing a new servo, I did not reset the RDT stab servo position line (line 10). I had tested the model without the stab and it looked “OK”. The first flight RDT the servo commanded the stab to the old position which was not enough to DT– fortunately this was a stab up rotation which put the model into a stall. If it had been a stab down rotation the model would have been in near bunt position– ouch. Lesson make sure to set RDT positon properly and test the total assembled system (this was also the Hubble Space Telescope lesson).


Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.